#21 – Req. Text Additional Price is not showing in Cart

Posted in ‘ReqText VirtueMart Plugin’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Tuesday, 14 July 2015 20:30 CEST
 Dear Sir or Madame hello,

I installed ReqText plugin on my website and it works fine when the user leaves the required fiends blank.

The problem though is that when I add a product to cart, in the cart the options that have additional fee (Lenses drop down list), in the cart the extra price is showing as zero.

Feel free to add a product in the cart and check it yourself:
http://anjoeyewear.com

Please advice.

Thank you for your time.

Best Regards,
Natasa
Custom Fields
ReqText Plugin version 1.51
info@webartworld.com
Tuesday, 14 July 2015 21:28 CEST
This should be fixed in version 1.51. Are you using that version or still version 1.5?
You can use the Joomla! update if you need to update the reqtext plugin (be sure you've entered the download ID in the plugin settings).

If you do have the latest version installed could you give me adminstrator access to your site so we can check the configuration of the plugin.
First set this ticket to PRIVATE before entering administrator account information.

Greetz, Nikolai van Nes
UWiX

Bug? That's not a bug, that's a feature. :-)

uwix
Tuesday, 14 July 2015 21:40 CEST
Hello and thank you for your answer,

It doesn't seem to have an option for changing the Public status of this ticket to private. I have only the option to Close this ticket.

But yes, I downloaded and installed the latest version of the plugin which is 1.51.

Regards,
Natasa
info@webartworld.com
Wednesday, 15 July 2015 10:31 CEST
Oops, sorry - it's set to private now. :-)

Bug? That's not a bug, that's a feature. :-)

uwix
Wednesday, 15 July 2015 11:17 CEST
Thank you! :)

Here are the login credentials that you will need:

[REMOVED]

Thank you very much!
info@webartworld.com
Wednesday, 15 July 2015 12:00 CEST
Just logged into your website and everything was set correctly. You've found a bug in the plugin.

When using the value 0 for a select option the filtering was to thight for the plugin. When showing the prices in the Shopping Cart the corresponding prices for a selection was changed and no value could be found. In that case the prices would be + €0,00.

Attached is an updated version which sould work correctly. Could you try it for me? It is a solid version so you can install it in your live version :-) Only two lines of code are changed in this version.

Please let me know it the problem is fixed using this new version.

Greetz, Nikolai van Nes
UWiX

Bug? That's not a bug, that's a feature. :-)

uwix
Wednesday, 15 July 2015 12:40 CEST
Hello!

Thank you for the quick work around! I installed the plugin, I tested it and it works ok, the cart is showing the correct prices.

I thought to check also the order & invoice that is created by virtuemart and I noticed that the Lenses value is still zero on the pdf invoice (I am attaching to you the invoice).

I am not sure though if the problem is because of ReqText or if I should ask support from Virtuemart!

Thank you again for your efforts! :)

Best Regards,
Natasa
info@webartworld.com
Wednesday, 15 July 2015 12:41 CEST
I am attaching the file as a png.. :)
info@webartworld.com
Wednesday, 15 July 2015 13:57 CEST
The same problem seems to appear on the confirmation emails.

So if I understood well the value that is added by ReqText is not saved in a database? Is it only for display purposes, without any communication with virtuemart table where prices are stored?

Natasa
info@webartworld.com
Wednesday, 15 July 2015 14:43 CEST
The ReqText value is not saved seperatly into the database - that's how the plugin system is setup in VirtueMart right now. The final price is the price which is calculated with the selected options from the ReqText plugin.

However, the added option and price is always added to the product description (as you've noticed in the PDF). This shouldn't be zero because that's not logical.

So, another attachment with another bugfix. That should do the trick for now. If not, please let me know.

Greetz, Nikolai van Nes
UWiX

p.s. the attached zip package has the same version number but isn't the same as the one you've downloaded earlier ;-)
 
uwixadmin
Wednesday, 15 July 2015 16:17 CEST
Hello,

THANK YOU very much for all the changes! Everything works fine now!!

This means that I will mark this ticked as closed!

Once again, thank you for your efforts!

Best Regards,
Natasa
info@webartworld.com
Wednesday, 15 July 2015 23:06 CEST
You're welcome - glad it worked out the way it should!

Greetz, Nikolai van Nes
UWiX

Bug? That's not a bug, that's a feature. :-)

uwix
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.
Support Availability

Working days: Monday to Friday. The is available 24 hours a day, 7 days a week but will only be answered during workings days according CET.
Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 48 hours. When we expect longer delays we will notify you when you file a ticket or reply.